Vulnérabilité: CVE-2020-4043

phpMussel des versions 1.0.0 et moins de 1.6.0 a une vulnérabilité dans l’emballage délinéarisation phar PHP. Le téléchargement d’un fichier spécialement conçu à une version affectée permet l’exécution de code arbitraire (découvert, testé et confirmé par moi-même), de sorte que le facteur de risque doit être considéré comme très élevé. Les nouvelles versions de phpMussel ne pas utiliser l’emballage phar de PHP, et ne sont donc pas affectés. Cela a été corrigé dans la version 1.6.0.


https://github.com/phpMussel/phpMussel/security/advisories/GHSA-qr95-4mq5-r3fh
https://github.com/phpMussel/phpMussel/commit/97f25973433921c1f953430f32d3081adc4851a4
https://github.com/phpMussel/phpMussel/issues/167
https://github.com/phpMussel/phpMussel/pull/173
https://github.com/phpMussel/phpMussel/security/policy#currently-known-vulnerabilities
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-4043


Il est possible de laisser un commentaire en tant qu'utilisateur enregistré du site, accédant par les réseaux sociaux, compte wordpress ou en tant qu'utilisateur anonyme. Si vous souhaitez laisser un commentaire en tant qu'utilisateur anonyme, vous serez informé par courrier électronique d'une réponse possible uniquement si vous saisissez votre adresse électronique (facultatif). L'inclusion de toute donnée dans les champs de commentaires est totalement facultative. Toute personne qui décide de saisir des données accepte le traitement de celles-ci pour les finalités inhérentes au service ou la réponse au commentaire et aux communications strictement nécessaires.


Laisser un commentaire