Vulnérabilité: CVE-2020-4059

Dans mversion avant 2.0.0, il existe une vulnérabilité d’injection de commande. Ce problème peut conduire à l’exécution de code à distance si un client de la bibliothèque appelle la méthode vulnérable des données non vérifiées. Cette vulnérabilité est patché par la version 2.0.0. Les versions précédentes sont déconseillés dans NPM. Pour contourner ce problème, assurez-vous de git échapper commits lorsque vous utilisez l’option commitMessage pour la fonction de mise à jour.


https://github.com/mikaelbr/mversion/security/advisories/GHSA-qjg4-w4c6-f6c6
https://github.com/mikaelbr/mversion/security/advisories/GHSA-qjg4-w4c6-f6c6
https://github.com/mikaelbr/mversion/commit/6c76c9efd27c7ff5a5c6f187e8b7a435c4722338
https://github.com/mikaelbr/mversion/commit/6c76c9efd27c7ff5a5c6f187e8b7a435c4722338
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-4059


Il est possible de laisser un commentaire en tant qu'utilisateur enregistré du site, accédant par les réseaux sociaux, compte wordpress ou en tant qu'utilisateur anonyme. Si vous souhaitez laisser un commentaire en tant qu'utilisateur anonyme, vous serez informé par courrier électronique d'une réponse possible uniquement si vous saisissez votre adresse électronique (facultatif). L'inclusion de toute donnée dans les champs de commentaires est totalement facultative. Toute personne qui décide de saisir des données accepte le traitement de celles-ci pour les finalités inhérentes au service ou la réponse au commentaire et aux communications strictement nécessaires.


Laisser un commentaire