Vulnérabilité: CVE-2020-8287

versions Node.js avant 10.23.1, 12.20.1, 14.15.4, 15.5.1 permettent deux copies d’un champ d’en-tête dans une requête HTTP (par exemple, deux champs d’en-tête Transfer-Encoding). Dans ce cas, Node.js identifie le premier champ d’en-tête et ne tient pas compte de la seconde. Cela peut conduire à Contrebande de requête HTTP.


https://www.debian.org/security/2021/dsa-4826
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/H472D5HPXN6RRXCNFML3BK5OYC52CXF2/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/K4I6MZNC7C7VIDQR267OL4TVCI3ZKAC4/
https://security.gentoo.org/glsa/202101-07
https://hackerone.com/reports/1002188
https://hackerone.com/reports/1002188
https://nodejs.org/en/blog/vulnerability/january-2021-security-releases/
https://nodejs.org/en/blog/vulnerability/january-2021-security-releases/
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-8287


Il est possible de laisser un commentaire en tant qu'utilisateur enregistré du site, accédant par les réseaux sociaux, compte wordpress ou en tant qu'utilisateur anonyme. Si vous souhaitez laisser un commentaire en tant qu'utilisateur anonyme, vous serez informé par courrier électronique d'une réponse possible uniquement si vous saisissez votre adresse électronique (facultatif). L'inclusion de toute donnée dans les champs de commentaires est totalement facultative. Toute personne qui décide de saisir des données accepte le traitement de celles-ci pour les finalités inhérentes au service ou la réponse au commentaire et aux communications strictement nécessaires.


Laisser un commentaire