Vulnérabilité: CVE-2021-21252

Le jQuery Validation Plugin fournit halte-validation de vos formes existantes. Il est publié en tant que paquet NPM « jquery-validation ». jquery validation avant la version 1.19.3 contient une ou plusieurs expressions régulières qui sont vulnérables aux ODER (expression régulière déni de service). Ce problème est résolu en 1.19.3.


https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-jxwx-85vp-gvwm
https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-jxwx-85vp-gvwm
https://github.com/jquery-validation/jquery-validation/commit/5d8f29eef363d043a8fec4eb86d42cadb5fa5f7d
https://github.com/jquery-validation/jquery-validation/commit/5d8f29eef363d043a8fec4eb86d42cadb5fa5f7d
https://github.com/jquery-validation/jquery-validation/pull/2371
https://github.com/jquery-validation/jquery-validation/pull/2371
https://www.npmjs.com/package/jquery-validation
https://www.npmjs.com/package/jquery-validation
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21252


Il est possible de laisser un commentaire en tant qu'utilisateur enregistré du site, accédant par les réseaux sociaux, compte wordpress ou en tant qu'utilisateur anonyme. Si vous souhaitez laisser un commentaire en tant qu'utilisateur anonyme, vous serez informé par courrier électronique d'une réponse possible uniquement si vous saisissez votre adresse électronique (facultatif). L'inclusion de toute donnée dans les champs de commentaires est totalement facultative. Toute personne qui décide de saisir des données accepte le traitement de celles-ci pour les finalités inhérentes au service ou la réponse au commentaire et aux communications strictement nécessaires.


Laisser un commentaire