Vulnerabilità: CVE-2006-2314

PostgreSQL 8.1.x prima 8.1.4, 8.0.x prima 8.0.8, 7.4.x prima 7.4.13, 7.3.15 7.3.x prima, e le versioni precedenti consente agli aggressori dipendenti dal contesto a metodi di protezione SQL injection by-pass in applicazioni che codifiche uso più byte che permettono al ""\"" (backslash) byte 0x5c di essere il byte finale di un carattere multibyte, come SJIS, BIG5, GBK, GB18030, e UHC, che non può essere gestito correttamente da un client che non capisce multibyte codifiche, aka una seconda variante di ""codifica basato su SQL Injection"". NOTA: si potrebbe sostenere che si tratta di una classe di problema relativo ad errori di interazione tra il cliente e PostgreSQL, ma un CVE è stato assegnato dal PostgreSQL è trattare questa come una misura preventiva contro questa classe di problema.


http://www.securityfocus.com/bid/18092
http://www.securityfocus.com/archive/1/435038/100/0/threaded
http://www.securityfocus.com/archive/1/435161/100/0/threaded
http://support.avaya.com/elmodocs2/security/ASA-2006-113.htm
http://www.postgresql.org/docs/techdocs.50
http://www.debian.org/security/2006/dsa-1087
http://security.gentoo.org/glsa/glsa-200607-04.xml
http://www.mandriva.com/security/advisories?name=MDKSA-2006:098
http://archives.postgresql.org/pgsql-announce/2006-05/msg00010.php
http://www.osvdb.org/25731
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9947
http://www.redhat.com/support/errata/RHSA-2006-0526.html
http://securitytracker.com/id?1016142
http://secunia.com/advisories/20231
http://secunia.com/advisories/20232
http://secunia.com/advisories/20314
http://secunia.com/advisories/20435
http://secunia.com/advisories/20451
http://secunia.com/advisories/20503
http://secunia.com/advisories/20555
http://secunia.com/advisories/20653
http://secunia.com/advisories/20782
http://secunia.com/advisories/21001
http://secunia.com/advisories/21749
http://lists.suse.com/archive/suse-security-announce/2006-Jun/0002.html
http://www.novell.com/linux/security/advisories/2006_21_sr.html
http://www.trustix.org/errata/2006/0032/
https://usn.ubuntu.com/288-1/
http://www.ubuntu.com/usn/usn-288-2
http://www.ubuntu.com/usn/usn-288-3
http://www.vupen.com/english/advisories/2006/1941
https://exchange.xforce.ibmcloud.com/vulnerabilities/26628
https://exchange.xforce.ibmcloud.com/vulnerabilities/26627
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2314


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi