Vulnerabilità: CVE-2018-11758


Questo riguarda Apache Cayenne 4.1.M1, 3.2.M1, 4.0.M2 a 4.0.M5, 4.0.B1, 4.0.B2, 4.0.RC1, 3.1, 3.1.1, 3.1.2. CayenneModeler è uno strumento di interfaccia grafica del desktop fornito con Apache Cayenne e destinati per l’editing di modelli Cayenne ORM memorizzati come file XML. Se un utente malintenzionato trucchi un utente di CayenneModeler ad aprire un file XML malevolo, l’attaccante sarà in grado di istruire il parser XML integrato in CayenneModeler per trasferire file da un computer locale a un computer remoto controllato dall’utente malintenzionato. La causa del problema è di entità esterna (XXE) le dichiarazioni XML trasformazione parser XML inclusi in XML. La vulnerabilità è indirizzata a Cayenne disabilitando l’elaborazione XXE in tutte le operazioni che richiedono l’analisi XML.
http://www.securityfocus.com/bid/105142
https://lists.apache.org/thread.html/[email protected]%3Cuser.cayenne.apache.org%3E
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11758

E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi