Vulnerabilità: CVE-2018-15560


PyCryptodome prima 3.6.6 ha un integer overflow nella variabile data_len in AESNI.c, relative alle funzioni AESNI_encrypt e AESNI_decrypt, portando alla cattiva gestione di messaggi brevi di 16 byte.
https://github.com/Legrandin/pycryptodome/issues/198
https://whitehatck01.blogspot.com/2018/08/integer-overflow-vulnerability-in.html
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15560

E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi