Vulnerabilità: CVE-2018-16435


Poco CMS (alias Piccolo Color Management System) 2,9 ha un integer overflow nella funzione AllocateDataSet in cmscgats.c, portando ad un overflow del buffer di heap-based nella funzione SetData tramite un file artigianale nel secondo argomento a cmsIT8LoadFromFile.
https://www.debian.org/security/2018/dsa-4284
https://github.com/mm2/Little-CMS/commit/768f70ca405cd3159d990e962d54456773bb8cf8
https://github.com/mm2/Little-CMS/issues/171
https://lists.debian.org/debian-lts-announce/2018/09/msg00005.html
https://access.redhat.com/errata/RHSA-2018:3004
https://usn.ubuntu.com/3770-1/
https://usn.ubuntu.com/3770-2/
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16435

E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi