Vulnerabilità: CVE-2018-16890


versioni libcurl da 7.36.0 a 7.64.0 prima è vulnerabile ad un cumulo tampone out-of-bounds leggono. La movimentazione NTLM entrante tipo 2 messaggi funzione ( `lib / Vauth / ntlm.c: ntlm_decode_type2_target`) non convalida correttamente i dati in entrata ed è soggetto ad una vulnerabilità integer overflow. Utilizzando che troppo pieno, di un server NTLM dannoso o rotto potrebbe ingannare libcurl ad accettare un cattivo lunghezza + combinazione di offset che porterebbe ad un buffer di lettura out-of-bounds.
http://www.securityfocus.com/bid/106947
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16890
https://cert-portal.siemens.com/productcert/pdf/ssa-436177.pdf
https://security.netapp.com/advisory/ntap-20190315-0001/
https://support.f5.com/csp/article/K03314397?utm_source=f5support&utm_medium=RSS
https://www.debian.org/security/2019/dsa-4386
https://curl.haxx.se/docs/CVE-2018-16890.html
https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
https://lists.apache.org/thread.html/[email protected]%3Cdevnull.infra.apache.org%3E
https://access.redhat.com/errata/RHSA-2019:3701
https://usn.ubuntu.com/3882-1/
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16890

E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi