Vulnerabilità: CVE-2018-20456


In radare2 prima 3.1.1, la funzione parseOperand all’interno LiBr / asm / p / asm_x86_nz.c può consentire attacchi di causare una negazione di servizio (crash dell’applicazione in LiBr / util / strbuf.c attraverso un buffer basato su stack over-lettura ) di lavorazione di un file di input, un problema correlato al CVE-2.018-20.455.
https://github.com/radare/radare2/commit/9b46d38dd3c4de6048a488b655c7319f845af185
https://github.com/radare/radare2/issues/12372
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20456

E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi