Vulnerabilità: CVE-2019-10669

Un problema è stato scoperto nel LibreNMS attraverso 1.47. C’è una vulnerabilità di iniezione di comando in html / include / grafici / dispositivo / collectd.inc.php cui parametri fornite dall’utente vengono filtrati con la funzione mysqli_escape_real_string. Questa funzione non è la funzione appropriata per argomenti di comando disinfettare quanto non sfugge una serie di caratteri di sintassi riga di comando come `(backtick), consentendo un attaccante di comandi iniettare nel $ rrd_cmd variabile, che viene eseguito tramite passante ().


http://packetstormsecurity.com/files/154391/LibreNMS-Collectd-Command-Injection.html
https://www.darkmatter.ae/xen1thlabs/librenms-command-injection-vulnerability-xl-19-017/
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10669


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi