Vulnerabilità: CVE-2019-12831

In MyBB prima 1.8.21, un utente malintenzionato può abusare di un comportamento di default di MySQL su molti sistemi (che porta al troncamento di stringhe che sono troppo lunghi per una colonna di database) per creare una shell PHP nella directory della cache di un forum mirato attraverso un importazione artigianale XML, come dimostrato da troncamento di aaaaaaaaaaaaaaaaaaaaaaaaaa.php.css ad aaaaaaaaaaaaaaaaaaaaaaaaaa.php con un limite di 30 caratteri, alias tema import nome foglio di stile RCE.


https://blog.mybb.com/2019/06/10/mybb-1-8-21-released-security-maintenance-release/
https://blog.ripstech.com/2019/mybb-stored-xss-to-rce/
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12831


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi