Vulnerabilità: CVE-2019-13115

In libssh2 prima 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c ha un integer overflow che potrebbe portare ad un fuori dal campo letta secondo il modo pacchetti vengono letti dal server. Un attaccante remoto che compromette un server SSH può essere in grado di rivelare informazioni sensibili o causare una condizione di Denial of service sul sistema client quando un utente si connette al server. Questo è legato ad un errore _libssh2_check_length, ed è diverso da vari problemi risolti in 1.8.1, come CVE-2019-3855.


https://security.netapp.com/advisory/ntap-20190806-0002/
https://support.f5.com/csp/article/K13322484
https://support.f5.com/csp/article/K13322484?utm_source=f5support&utm_medium=RSS
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/M7IF3LNHOA75O4WZWIHJLIRMA5LJUED3/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6LUNHPW64IGCASZ4JQ2J5KDXNZN53DWW/
https://blog.semmle.com/libssh2-integer-overflow/
https://github.com/libssh2/libssh2/compare/02ecf17…42d37aa
https://github.com/libssh2/libssh2/pull/350
https://libssh2.org/changes.html
https://lists.debian.org/debian-lts-announce/2019/07/msg00024.html
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-13115


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi