Vulnerabilità: CVE-2019-14751

NLTK Downloader 3.4.5 prima è vulnerabile ad un attraversamento directory, permettendo agli hacker di scrivere file arbitrari tramite un ../ (dot barra punto) in un pacchetto NLTK (ZIP archivio) che viene maltrattato durante l’estrazione.


https://github.com/nltk/nltk/blob/3.4.5/ChangeLog
https://github.com/nltk/nltk/commit/f59d7ed8df2e0e957f7f247fe218032abdbe9a10
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QI4IJGLZQ5S7C5LNRNROHAO2P526XE3D/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZGZSSEJH7RHH3RBUEVWWYT75QU67J7SE/
https://github.com/mssalvatore/CVE-2019-14751_PoC
https://salvatoresecurity.com/zip-slip-in-nltk-cve-2019-14751/
http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00054.html
http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00001.html
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14751


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi