Vulnerabilità: CVE-2020-13904

FFmpeg 2.8 e 4.2.3 ha un uso-after-free tramite una durata EXTINF artigianale in un file M3U8 perché parse_playlist in libavformat / hls.c libera un puntatore, e più tardi che il puntatore si accede in av_probe_input_format3 in libavformat / format.c.


https://www.debian.org/security/2020/dsa-4722
https://security.gentoo.org/glsa/202007-58
https://github.com/FFmpeg/FFmpeg/commit/6959358683c7533f586c07a766acc5fe9544d8b2
https://patchwork.ffmpeg.org/project/ffmpeg/patch/20200529033905.41926-1-lq@chinaffmpeg.org/
https://trac.ffmpeg.org/ticket/8673
https://lists.debian.org/debian-lts-announce/2020/07/msg00022.html
https://usn.ubuntu.com/4431-1/
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-13904


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi