Vulnerabilità: CVE-2020-14338

Un difetto è che, nella realizzazione di wildfly di Xerces, in particolare nel modo in cui la classe XMLSchemaValidator nel componente JAXP del wildfly applicata la funzione ""uso Grammatica-piscina-only"". Questo difetto consente a un file XML appositamente predisposto per manipolare il processo di validazione in alcuni casi. Questo problema è lo stesso difetto come CVE-2.020-14.621, che ha interessato OpenJDK, e utilizza un codice simile. Questa falla interessa tutte le versioni di JBoss Xerces prima 2.12.0.SP3.


https://bugzilla.redhat.com/show_bug.cgi?id=1860054
https://bugzilla.redhat.com/show_bug.cgi?id=1860054
https://lists.apache.org/thread.html/rf96c5afb26b596b4b97883aa90b6c0b0fc4c26aaeea7123c21912103@%3Cj-users.xerces.apache.org%3E
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14338


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi