Vulnerabilità: CVE-2020-15095

Le versioni del CLI NPM prima 6.14.6 sono vulnerabili ad una vulnerabilità di esposizione informazioni attraverso i file di log. I supporti CLI URL del tipo ""<protocol>: // [<utente> [: <password>] @] <nome host> [: <porta>] [:] [/] <percorso>"". Il valore di password non viene redatto ed è stampato su stdout e anche a tutti i file di log generati.


https://github.com/npm/cli/security/advisories/GHSA-93f3-23rq-pjfp
https://github.com/npm/cli/security/advisories/GHSA-93f3-23rq-pjfp
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4OOYAMJVLLCLXDTHW3V5UXNULZBBK4O6/
https://security.gentoo.org/glsa/202101-07
https://github.com/npm/cli/blob/66aab417f836a901f8afb265251f761bb0422463/CHANGELOG.md#6146-2020-07-07
https://github.com/npm/cli/blob/66aab417f836a901f8afb265251f761bb0422463/CHANGELOG.md#6146-2020-07-07
https://github.com/npm/cli/commit/a9857b8f6869451ff058789c4631fadfde5bbcbc
https://github.com/npm/cli/commit/a9857b8f6869451ff058789c4631fadfde5bbcbc
http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00011.html
http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00015.html
http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00023.html
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-15095


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi