Vulnerabilità: CVE-2020-15109

In solidus prima versioni 2.8.6, 2.9.6 e 2.10.2, c’è un bilità di indirizzo di ordine di cambiamento senza innescare convalide di indirizzo. Questa vulnerabilità consente a un cliente malintenzionato di dati richiesta mestiere con i parametri che consentono di cambiare l’indirizzo del l’ordine corrente senza modificare le spese di spedizione associate alla nuova spedizione. Tutti i negozi con almeno due zone di trasporto e diversi costi di spedizione per zona sono influenzati. Questo problema deriva dal modo in attributi checkout consentito sono strutturati. Abbiamo un unico elenco di attributi che sono consentiti in tutta la cassa, non importa il passo che viene presentato. Vedere il riferimento collegato per ulteriori informazioni. Come soluzione alternativa, se non è possibile eseguire l’aggiornamento a una versione modificata supportata, si prega di utilizzare questa sostanza nella sezione riferimenti.


https://github.com/solidusio/solidus/security/advisories/GHSA-3mvg-rrrw-m7ph
https://github.com/solidusio/solidus/security/advisories/GHSA-3mvg-rrrw-m7ph
https://gist.github.com/kennyadsl/4618cd9797984cb64f7700a81bda889d
https://gist.github.com/kennyadsl/4618cd9797984cb64f7700a81bda889d
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-15109


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi