Vulnerabilità: CVE-2020-15256

Una vulnerabilità di inquinamento prototipo è stato trovato in `oggetto-path` <= 0.11.4 influenzare il` set) il metodo ( `. La vulnerabilità è limitata alla modalità `includeInheritedProps` (se> = 0.11.0 versione utilizzata), che deve essere esplicitamente abilitata creando una nuova istanza di oggetto`-path` e impostando le `includeInheritedProps opzioni: true`, o utilizzando l’impostazione predefinita `istanza withInheritedProps`. La modalità operativa di default non è interessato dalla vulnerabilità, se viene utilizzata la versione> = 0.11.0. Qualsiasi utilizzo di `set ()` nelle versioni <0.11.0 è vulnerabile. Il problema è risolto in oggetto-path versione 0.11.5 Per risolvere il problema, non utilizzare i `includeInheritedProps: opzioni true` o l’istanza` withInheritedProps` se si utilizza una versione> = 0.11.0.


https://github.com/mariocasciaro/object-path/security/advisories/GHSA-cwx2-736x-mf6w
https://github.com/mariocasciaro/object-path/security/advisories/GHSA-cwx2-736x-mf6w
https://github.com/mariocasciaro/object-path/commit/2be3354c6c46215c7635eb1b76d80f1319403c68
https://github.com/mariocasciaro/object-path/commit/2be3354c6c46215c7635eb1b76d80f1319403c68
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-15256


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi