Vulnerabilità: CVE-2020-1955

CouchDB versione 3.0.0 fornita con una nuova impostazione di configurazione che controllano l’accesso governa a tutto il server di database chiamato `require_valid_user_except_for_up`. E ‘stato concepito come estensione alla lunga data impostazione `require_valid_user`, che a sua volta richiede che qualsiasi e tutte le richieste di CouchDB dovranno essere realizzati con credenziali valide, vietando in modo efficace eventuali richieste anonime. Il nuovo `require_valid_user_except_for_up` è un ambiente off-by-default che avrebbe dovuto permettere che richiedono credenziali valide per tutti gli endpoint ad eccezione del` / _up` endpoint. Tuttavia, l’attuazione di questo ha fatto un errore che portano a non far rispettare le credenziali su qualsiasi endpoint, se abilitato. versioni CouchDB 3.0.1 [1] e 3.1.0 [2] risolvere questo problema.


https://docs.couchdb.org/en/master/cve/2020-1955.html
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-1955


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi