Vulnerabilità: CVE-2020-1959

Un’iniezione-Side Server Template è stato identificato in Apache Syncope prima 2.1.6 attaccanti che permettono di iniettare arbitrarie espressioni Java EL, portando ad una distanza l’esecuzione di codice (RCE) la vulnerabilità non autenticato. Apache Syncope utilizza Java Bean Validation (JSR 380) validatori vincolo personalizzato. Quando si costruisce messaggi di errore personalizzati violazione di vincolo, che supportano diversi tipi di interpolazione, comprese le espressioni Java EL. Pertanto, se un utente malintenzionato può iniettare dati arbitrari nel modello messaggio di errore di essere passati, essi saranno in grado di eseguire codice arbitrario Java.


http://syncope.apache.org/security
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-1959


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi