Vulnerabilità: CVE-2020-25814

In MediaWiki prima 1.31.10 e 1.32.x attraverso 1.34.x prima 1.34.4, XSS correlate a jQuery può verificarsi. L’attaccante crea un messaggio con [javascript: payload XSS]. E lo trasforma in un oggetto jQuery con mw.message () parse (). Il risultato atteso è che l’oggetto jQuery non contiene un tag <a> (o non avere un attributo href, o è vuoto, ecc). Il risultato attuale è che l’oggetto contiene un <a href = ""javascript … che viene eseguito quando si fa clic.


https://lists.wikimedia.org/pipermail/mediawiki-l/2020-September/048480.html
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RTTPZ7XMDS66I442OLLHXBDNP2LCBJU6/
https://lists.wikimedia.org/pipermail/mediawiki-l/2020-September/048488.html
https://www.mediawiki.org/wiki/ResourceLoader/Core_modules#mediawiki.jqueryMsg
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25814


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi