Vulnerabilità: CVE-2020-25860

Il modulo install.c nel client di aggiornamento Pengutronix Rauc precedenti alla versione 1.5 ha una vulnerabilità Time-of-Check Time-of-Use, in cui la verifica della firma su un file di aggiornamento avviene prima che il file viene riaperto per l’installazione. Un utente malintenzionato che può modificare il file di aggiornamento appena prima che viene riaperto può installare codice arbitrario sul dispositivo.


https://github.com/rauc/rauc/security/advisories/GHSA-cgf3-h62j-w9vv
https://github.com/rauc/rauc/security/advisories/GHSA-cgf3-h62j-w9vv
https://www.vdoo.com/blog/cve-2020-25860-significant-vulnerability-discovered-rauc-embedded-firmware-update-framework
https://www.vdoo.com/blog/cve-2020-25860-significant-vulnerability-discovered-rauc-embedded-firmware-update-framework
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25860


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi