Vulnerabilità: CVE-2020-26284

Hugo è un veloce e flessibile Statico Generator sito costruito in Go. Hugo dipende Go `os / exec` per alcune funzioni, ad esempio, per il rendering di documenti Pandoc se questi binari si trovano nel sistema di “% PATH% su Windows. In Hugo prima della versione 0.79.1, se un file malevolo con lo stesso nome ( “ exe` o bat`) si trova nella directory di lavoro corrente al momento della esecuzione `hugo`, il comando dannoso verrà invocato al posto del sistema di uno. Gli utenti Windows che eseguono `hugo` all’interno non attendibili i siti Hugo sono interessati. Gli utenti devono eseguire l’aggiornamento a Hugo v0.79.1. Altro che evitando non attendibili siti Hugo, non v’è alcuna soluzione.


https://github.com/gohugoio/hugo/security/advisories/GHSA-8j34-9876-pvfq
https://github.com/gohugoio/hugo/security/advisories/GHSA-8j34-9876-pvfq
https://github.com/golang/go/issues/38736
https://github.com/golang/go/issues/38736
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-26284


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi