Vulnerabilità: CVE-2020-27813

Una vulnerabilità di integer overflow con la lunghezza di frame websocket ricevuti tramite una connessione websocket. Un utente malintenzionato potrebbe utilizzare questa falla per causare un attacco denial of service su un server HTTP che permette connessioni websocket.


https://bugzilla.redhat.com/show_bug.cgi?id=1902111
https://bugzilla.redhat.com/show_bug.cgi?id=1902111
https://github.com/gorilla/websocket/security/advisories/GHSA-jf24-p9p9-4rjh
https://github.com/gorilla/websocket/security/advisories/GHSA-jf24-p9p9-4rjh
https://lists.debian.org/debian-lts-announce/2021/01/msg00008.html
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-27813


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi