Vulnerabilità: CVE-2020-29587

SimplCommerce 1.0.0-rc utilizza la libreria Bootbox.js, che permette la creazione di finestre di dialogo programmatiche utilizzando modali Bootstrap. La libreria Bootbox.js intenzionalmente non esegue alcuna sanificazione di input dell’utente, che si traduce in un DOM XSS, perché utilizza la funzione jQuery html () per direttamente accodamento il carico utile ad una finestra.


https://github.com/simplcommerce/SimplCommerce/issues/969
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-29587


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi