Vulnerabilità: CVE-2020-4052

In Wiki.js prima 2.4.107, c’è un cross-site scripting memorizzati attraverso l’iniezione modello. La vulnerabilità è dovuta ad un meccanismo di validazione insicuro desiderare inserire tag v-pre in elementi HTML fusi che contengono parentesi graffe. Con la creazione di una pagina wiki artigianale, un utente malintenzionato può Wiki.js in scena un attacco di scripting cross-site memorizzato. Questo permette al malintenzionato di eseguire JavaScript maligno quando la pagina viene visualizzata da altri utenti. Questo è stato aggiornato in 2.4.107.


https://github.com/Requarks/wiki/security/advisories/GHSA-9jgg-4xj2-vjjj
https://github.com/Requarks/wiki/security/advisories/GHSA-9jgg-4xj2-vjjj
https://github.com/Requarks/wiki/commit/9e08718ee904046f8b2294ef6ac79e8a75a451e3
https://github.com/Requarks/wiki/commit/9e08718ee904046f8b2294ef6ac79e8a75a451e3
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-4052


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi