Vulnerabilità: CVE-2020-5220

Sylius ResourceBundle accetta e utilizza nessun gruppo serializzazione da passare attraverso un header HTTP. Questo potrebbe portare ad esposizione dei dati utilizzando un gruppo di serializzazione non intenzionale – per esempio potrebbe fare regali API usa un gruppo più permissiva da Admin API. Chiunque esponendo un’API con il controller di ResourceBundle è interessato. Le versioni vulnerabili sono: <1.3 || > = 1.3.0 <= 1.3.12 || > = 1.4.0 <= 1.4.5 || > = 1.5.0 <= 1.5.0 || > = 1.6.0 <= 1.6.2. La patch è previsto per Sylius ResourceBundle 1.3.13, 1.4.6, 1.5.1 e 1.6.3, ma non per tutte le versioni inferiori a 1.3.


https://github.com/Sylius/SyliusResourceBundle/security/advisories/GHSA-8vp7-j5cj-vvm2
https://github.com/FriendsOfPHP/security-advisories/blob/master/sylius/resource-bundle/CVE-2020-5220.yaml
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-5220


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi