Vulnerabilità: CVE-2020-7748

Questo influenza il pacchetto @ tsed / core prima 5.65.7. Questa vulnerabilità riguarda la funzione deepExtend che viene usato come parte della directory utils. A seconda se viene fornito l’input dell’utente, un utente malintenzionato può sovrascrivere e inquinare il prototipo oggetto di un programma.


https://github.com/TypedProject/tsed/blob/production/packages/core/src/utils/deepExtends.ts%23L36
https://github.com/TypedProject/tsed/blob/production/packages/core/src/utils/deepExtends.ts%23L36
https://github.com/TypedProject/tsed/commit/1395773ddac35926cf058fc6da9fb8e82266761b
https://github.com/TypedProject/tsed/commit/1395773ddac35926cf058fc6da9fb8e82266761b
https://snyk.io/vuln/SNYK-JS-TSEDCORE-1019382
https://snyk.io/vuln/SNYK-JS-TSEDCORE-1019382
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-7748


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi