Vulnerabilità: CVE-2020-7754

Questo influenza il pacchetto di NPM-user-validate prima della 1.0.1. L’espressione regolare che convalida le email degli utenti si è esponenzialmente più tempo per elaborare le stringhe di input lunghe che iniziano con @ caratteri.


https://github.com/npm/npm-user-validate/commit/c8a87dac1a4cc6988b5418f30411a8669bef204e
https://github.com/npm/npm-user-validate/commit/c8a87dac1a4cc6988b5418f30411a8669bef204e
https://github.com/npm/npm-user-validate/security/advisories/GHSA-xgh6-85xh-479p
https://github.com/npm/npm-user-validate/security/advisories/GHSA-xgh6-85xh-479p
https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1019353
https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1019353
https://snyk.io/vuln/SNYK-JS-NPMUSERVALIDATE-1019352
https://snyk.io/vuln/SNYK-JS-NPMUSERVALIDATE-1019352
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-7754


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi