Vulnerabilità: CVE-2021-21242

OneDev è una piattaforma all-in-one DevOps. In OneDev prima versione 4.0.3, esiste una vulnerabilità critica che può portare a pre-auth esecuzione di codice remoto. AttachmentUploadServlet deserializza i dati non attendibili dalla testata `Allegato-Support`. Questo Servlet non applica alcuna autenticazione o di autorizzazione assegni. Questo problema può portare a pre-auth esecuzione di codice remoto. Questo problema è stato risolto in 4.0.3, rimuovendo AttachmentUploadServlet e che non utilizzano deserializzazione


https://github.com/theonedev/onedev/security/advisories/GHSA-5q3q-f373-2jv8
https://github.com/theonedev/onedev/security/advisories/GHSA-5q3q-f373-2jv8
https://github.com/theonedev/onedev/commit/f864053176c08f59ef2d97fea192ceca46a4d9be
https://github.com/theonedev/onedev/commit/f864053176c08f59ef2d97fea192ceca46a4d9be
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21242


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi