Vulnerabilità: CVE-2021-21248

OneDev è una piattaforma all-in-one DevOps. In OneDev prima della versione 4.0.3, v’è una vulnerabilità critica che coinvolge i parametri di compilazione endpoint. InputSpec viene utilizzato per definire i parametri di una specifica Genera. Lo fa utilizzando le classi Groovy generate in modo dinamico. Un utente in grado di parametri del lavoro di controllo in grado di eseguire codice arbitrario sul server del OneDev iniettando arbitrario codice Groovy. Il risultato finale è l’iniezione di un costruttore statico che verrà eseguito codice arbitrario. Per un esempio completo consultare il GHSA riferimento. Questo problema è stato affrontato in 4.0.3 per sfuggire caratteri speciali come citazione da input dell’utente.


https://github.com/theonedev/onedev/security/advisories/GHSA-gwp4-5498-hv5f
https://github.com/theonedev/onedev/security/advisories/GHSA-gwp4-5498-hv5f
https://github.com/theonedev/onedev/commit/39d95ab8122c5d9ed18e69dc024870cae08d2d60
https://github.com/theonedev/onedev/commit/39d95ab8122c5d9ed18e69dc024870cae08d2d60
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21248


E' possibile lasciare un commento come utenti registrati al sito, accedendo tramite social, account wordpress oppure come utenti anonimi. Nel caso in cui si desideri lasciare un commento come utenti anonimi si verrà avvisati via email di un'eventuale risposta solo se si inserisce l'indirizzo email (facoltativo). L'inserimento di qualsiasi dato nei campi dei commenti è totalmente facoltativo. Chiunque decida di inserire un qualsiasi dato accetta il trattamento di questi ultimi per i fini inerenti al servizio ovvero la risposta al commento e le comunicazioni strettamente necessarie.


Rispondi